【iOS】iOS15で、”Appを このバージョンのiOSで動作させるには、デベロッパーによるアップデートが必要です”

"(iOSアプリ名)" はアップデートの必要があります

ありがちな、iOSのメジャーバージョンアップで、デベロッパー側として、対応が必要になったので備忘。

最新のメジャーOSでは、よくあることなのかもしれませんが、iOS14.5 でも発生していたとか。。

経緯

開発中のDeveloper版のIAPで発生。
Prod版(AppStore版)のリリース中のAppには影響なかった。

クライアント:
iOS15.0

開発用のDevelop版の*.iapを端末にインストールしようとすると、表題・アイキャッチ画像のメッセージが表示される。

対策

シンプルに、iOS15に対応している XCode12.5系でビルドする。

とりあえず、母艦のiMacと合わせて、Mac Book Proも。
ついでに、Apple TV、HomePod、iPadもアップデートしておいた。

解消するといいけど。

とりあえず、現段階でUnity CloudのXCodeは、12.4.x系しか存在してなかった。

新しいメジャーバージョンを使う人の宿命ですね。(開発する側も大変x2)
最近リリースノートを全く追えてない。。。